您的位置:首页 > Web前端 > AngularJS

NYOJ 122 Triangular Sums

2014-02-15 14:44 288 查看


Triangular Sums

时间限制:3000 ms | 内存限制:65535 KB
难度:2

描述

The nth Triangular number, T(n) = 1 + … + n, is the sum of the first n integers. It is the number of points in a triangular array with n points
on side. For example T(4):

X

X X

X X X

X X X X

Write a program to compute the weighted sum of triangular numbers:

W(n) =
SUM[k = 1…n; k * T(k + 1)]


输入
The first line of input contains a single integer N, (1 ≤ N ≤ 1000) which is the number of datasets that follow.

Each dataset consists of a single line of input containing a single integer n, (1 ≤ n ≤300), which is the number of points on a side of the triangle.
输出
For each dataset, output on a single line the dataset number (1 through N), a blank, the value of n for the dataset, a blank, and the weighted sum ,W(n), of triangular numbers for n.
样例输入
4
3
4
5
10


样例输出
1 3 45
2 4 105
3 5 210
4 10 2145


思路:略。

#include <stdio.h>

int main()
{
int m,n,i,t=1;
int a[302];
scanf("%d",&m);
for (i=1; i<302; i++)
{
a[i] = i*(i+1) / 2;
}
while (m--)
{
int sum = 0;
scanf("%d",&n);
for (i=1; i<=n; i++)
{
sum += i*a[i+1];
}
printf("%d %d %d\n",t,n,sum);
t++;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: