您的位置:首页 > 理论基础 > 数据结构算法

寒假第三天--栈和队列--数据结构实验之栈二:一般算术表达式转换成后缀式

2014-01-16 19:06 387 查看

数据结构实验之栈二:一般算术表达式转换成后缀式

Time Limit: 1000MS Memory limit: 65536K

题目描述

对于一个基于二元运算符的算术表达式,转换为对应的后缀式,并输出之。

输入

输入一个算术表达式,以‘#’字符作为结束标志。

输出

输出该表达式转换所得到的后缀式。

示例输入

a*b+(c-d/e)*f#


示例输出

ab*cde/-f*+


提示

 

.
中缀表达式转换成后缀表达式。
 
首先创建栈并置空,然后依次检查中缀表达式每个字符,不同字符按不同情况处理:
 

(1).
若是操作数,就直接将存入字符串exp[]中。
 (2).
若是‘(’则将其压入栈中。
 (3).
若是‘)’则依次弹栈并存入字符串exp[]中,直到遇到取出和它匹配的‘(’为止,‘(’出栈丢弃。
 (4).
若是操作符,如果栈空或者该操作符的优先级大于栈顶操作符则将其放入到栈中。如果该操作符的优先级小于等于栈顶操作符则弹出栈中的操作符存入字符串exp[]中,直到该操作符的优先级大于栈顶操作符或栈空,然后将该操作符入栈。当读到了中缀式的末尾时,如果栈非空则将栈中所有元素依次弹出存入字符串exp[]中,最后见‘\0’存入exp[]中,则exp[]中存储的就是后缀表达式。

来源

 

示例程序

#include <stdio.h>
#include <string.h>
int f(char ch, char sh)
{
if(sh=='(') return 1;
if( (ch=='*' || ch=='/' || ch=='%')&&( sh=='+' || sh=='-')  )
return 1;
else
return -1;
}
int main()
{
int i = 0 , n , top = -1 ;
char exp[1000] , str[1000] , ch ;
while(scanf("%c", &ch) && ch != '#')
{
if(ch >= 'a' && ch <='z')
exp[i++] = ch ;
else if(ch=='(')
str[++top] = ch ;
else if(ch==')')
{
while(top!=-1)
{
exp[i++] = str[top];
top--;
if(str[top]=='(')
{
top--;
break;
}
}
}
else
{
if(top == -1 || f(ch,str[top]) > 0 )
str[++top] = ch ;
else
{
while(top >=0 && f(ch,str[top]) < 0  )
{
exp[i++] = str[top--];
}
str[++top] = ch ;
}
}
}
while(top != -1)
{
exp[i++] = str[top--];
}
exp[i] = '\0';
printf("%s\n", exp);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: