您的位置:首页 > 理论基础 > 数据结构算法

poj1611-The Suspects--并查集

2013-10-18 18:55 357 查看
The Suspects

Time Limit: 1000MS Memory Limit: 20000K
Total Submissions: 19318 Accepted: 9366
Description

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others. 

In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects
the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP). 

Once a member in a group is a suspect, all members in the group are suspects. 

However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.
Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer
between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group.
Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space. 

A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.
Output

For each case, output the number of suspects in one line.
Sample Input
100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0

Sample Output
4
1
1

Source

Asia Kaohsiung 2003

第一次写并查集。。。感觉果真还是很基础的数据结构。

ORZ,我好弱啊~~~~~~。。。。

顺带加了路径压缩+返回高度最小(秩最小)树的优化。

当做并查集类型的第一个模板,

以下是代码(注释里说的很清楚了):

#include <cstdio>
#include <cstdlib>
using namespace std;
const int maxnum=3e4+100;//结点数目上界

int pa[maxnum];//pa存储的是每个节点的父亲
int rank[maxnum];//rank存储的是x所属的集合的树的高度
int num[maxnum];//num存储的是x所属的集合中的元素的数量

void initial(int n) //初始化全部集合信息
{
for(int i=0;i<n;++i)
{
pa[i]=i;
rank[i]=0;
num[i]=1;
}
}

//递归版本
int grand_pa(int x) //寻找x的祖先
{
if(x!=pa[x])
pa[x]=grand_pa(pa[x]);
return pa[x];
}

void union_set(int x,int y)//将x和y两个元素所属的元素集合合并,秩小的并给秩大的
{
int a=grand_pa(x);//x的祖先
int b=grand_pa(y);//y的祖先
if(a==b) return;//这里一定要记得啊!wrong了好几炮的= =#
if(rank[a]>rank[b])
{
pa[b]=a;
num[a]+=num[b];
}
else
{
pa[a]=b;
if(rank[a]==rank[b]) //如果二者高度相等,就把树的高度加一
++rank[b];
num[b]+=num[a];
}
}

int main()
{
//freopen("input.txt","r",stdin);
int m,n;
while(scanf("%d%d",&m,&n)!=EOF)
{
if(m==0&&n==0) break;
initial(m);
for(int i=0;i<n;++i)
{
int size,first,next;
scanf("%d%d",&size,&first);
for(int j=1;j<size;++j)
{
scanf("%d",&next);
union_set(first,next);
}
}
printf("%d\n",num[grand_pa(0)]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  acm poj 数据结构