您的位置:首页 > 大数据 > 物联网

UVa 10881 Piotr's Ants (等价转化思想)

2013-09-01 16:41 246 查看


10881 - Piotr's Ants

Time limit: 3.000 seconds

http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=456&page=show_problem&problem=1822

"One thing is for certain: there is no stopping them;

the ants will soon be here. And I, for one, welcome our

new insect overlords."
Kent Brockman
Piotr likes playing with ants. He has n of them on a horizontal pole L cm long. Each ant is facing either left or right and walks at a constant speed of 1 cm/s. When
two ants bump into each other, they both turn around (instantaneously) and start walking in opposite directions. Piotr knows where each of the ants starts and which direction it is facing and wants to calculate where the ants will end up T seconds
from now.
Input

The first line of input gives the number of cases, N. N test cases follow. Each one starts with a line containing 3 integers: L , T and n (0 <= n <=
10000). The next n lines give the locations of the n ants (measured in cm from the left end of the pole) and the direction they are facing (L or R).
Output

For each test case, output one line containing "Case #x:" followed by n lines describing the locations and directions of the n ants in the same format and order as in the input. If two or more ants are at the
same location, print "Turning" instead of "L" or "R" for their direction. If an ant falls off the pole before Tseconds, print "Fell off" for that ant. Print an empty line after each test case.
Sample InputSample Output
2
10 1 4
1 R
5 R
3 L
10 R
10 2 3
4 R
5 L
8 R

Case #1:
2 Turning
6 R
2 Turning
Fell off

Case #2:
3 L
6 R
10 R

思路:

1. 掉头等价于对穿而过

2. 所有蚂蚁的相对顺序不变

3. 注意将T秒时位置相同的蚂蚁标记为“Turning”

4. 用三个数组,分别记录输入的顺序和T秒前后的位置

完整代码:

/*0.039s*/

#include<cstdio>
#include<algorithm>
using namespace std;
const int maxn = 10000 + 5;
const char dirName[][10] = {"L", "Turning", "R"};

struct Ant
{
	int id; // 输入顺序
	int p;  // 位置
	int d;  // 朝向。 -1: 左; 0:转身中; 1:右
	bool operator < (const Ant& a) const
	{
		return p < a.p;
	}
} before[maxn], after[maxn];

int order[maxn]; // 输入的第i只蚂蚁是终态中的左数第order[i]只蚂蚁

int main(void)
{
	int K;
	scanf("%d", &K);
	for (int kase = 1; kase <= K; kase++)
	{
		int L, T, n;
		printf("Case #%d:\n", kase);
		scanf("%d%d%d", &L, &T, &n);
		for (int i = 0; i < n; i++)
		{
			int p, d;
			char c;
			scanf("%d %c", &p, &c);
			d = (c == 'L' ? -1 : 1);
			before[i] = (Ant)
			{
				i, p, d
			}; // 类型转换技巧~
			after[i] = (Ant)
			{
				0, p + T*d, d
			}; // 这里的id是未知的
		}
		
		// 计算order数组
		sort(before, before + n);
		for (int i = 0; i < n; i++)
			order[before[i].id] = i;
			
		// 计算终态
		sort(after, after + n);
		for (int i = 0; i < n - 1; i++) // 修改碰撞中的蚂蚁的方向
			if (after[i].p == after[i + 1].p) after[i].d = after[i + 1].d = 0;
			
		// 输出结果
		for (int i = 0; i < n; i++)
		{
			int a = order[i];
			if (after[a].p < 0 || after[a].p > L) printf("Fell off\n");
			else printf("%d %s\n", after[a].p, dirName[after[a].d + 1]);
		}
		printf("\n");
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: