您的位置:首页 > 编程语言 > Go语言

2345_Gold Coins(输入分多个块,每个块中有多行,每个输入块之间有空格,但最后没有空格)

2013-04-21 23:18 399 查看
The king pays his loyal knight in gold coins. On the first day of his service, the knight receives one gold coin. On each of the next two days (the second and third days of service), the knight receives two gold coins. On each of the next three days (the
fourth, fifth, and sixth days of service), the knight receives three gold coins. On each of the next four days (the seventh, eighth, ninth, and tenth days of service), the knight receives four gold coins. This pattern of payments will continue indefinitely:
after receiving N gold coins on each of N consecutive days, the knight will receiveN+1 gold coins on each of the nextN+1 consecutive days, where
N is any positive integer.

Your program will determine the total number of gold coins paid to the knight in any given number of days (starting from Day 1).

This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.

Input

Each input block contains at least one, but no more than 21 lines. Each line of the input (except the last one) contains data for one test case of the problem, consisting of exactly one integer (in the range 1..10000), representing the number of days. The
end of the input is signaled by a line containing the number 0.

Output

There is exactly one line of output for each test case. This line contains the number of days from the corresponding line of input, followed by one blank space and the total number of gold coins paid to the knight in the given number of days, starting with
Day 1.

Sample Input

1

10

6

7

11

15

16

100

10000

1000

21

22

0

Sample Output

10 30

6 14

7 18

11 35

15 55

16 61

100 945

10000 942820

1000 29820

21 91

22 98

Source: Rocky Mountain 2004

//第一天给一块,然后两天各给两块,然后三天各给三块,输入天数,求块数
//输入输出很讲究,输入分多个块,每个块中有多行,每个输入块之间有空格,但最后没有空格。
#include<iostream>
using namespace std;
int main()
{
int day,coin;
int i,j,dd;
int num;//块号
cin>>num;
while(num--)
{
while(cin>>day&&day)
{
if(day==0)
break;
dd=i=coin=0;
while(dd<day)
{
i++;
dd+=i;
}
dd-=i;
for(j=1;j!=i;j++)
coin+=j*j;
coin+=(day-dd)*i;
cout<<day<<" "<<coin<<endl;
}
if(num!=0)//每个输入块之间有空格,但最后没有空格
cout<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: 
相关文章推荐