您的位置:首页 > 理论基础 > 计算机网络

http://acm.hdu.edu.cn/showproblem.php?pid=1548

2013-01-22 10:03 344 查看

A strange lift

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 7032 Accepted Submission(s): 2658



[align=left]Problem Description[/align]
There is a strange lift.The lift can stop can at every floor as you want, and there is a number Ki(0 <= Ki <= N) on every floor.The lift have just two buttons: up and down.When you at floor i,if you press the button "UP" , you will
go up Ki floor,i.e,you will go to the i+Ki th floor,as the same, if you press the button "DOWN" , you will go down Ki floor,i.e,you will go to the i-Ki th floor. Of course, the lift can't go up high than N,and can't go down lower than 1. For example, there
is a buliding with 5 floors, and k1 = 3, k2 = 3,k3 = 1,k4 = 2, k5 = 5.Begining from the 1 st floor,you can press the button "UP", and you'll go up to the 4 th floor,and if you press the button "DOWN", the lift can't do it, because it can't go down to the -2
th floor,as you know ,the -2 th floor isn't exist.

Here comes the problem: when you are on floor A,and you want to go to floor B,how many times at least he has to press the button "UP" or "DOWN"?

[align=left]Input[/align]
The input consists of several test cases.,Each test case contains two lines.

The first line contains three integers N ,A,B( 1 <= N,A,B <= 200) which describe above,The second line consist N integers k1,k2,....kn.

A single 0 indicate the end of the input.

[align=left]Output[/align]
For each case of the input output a interger, the least times you have to press the button when you on floor A,and you want to go to floor B.If you can't reach floor B,printf "-1".

[align=left]Sample Input[/align]

5 1 5
3 3 1 2 5
0


[align=left]Sample Output[/align]

3


#include<iostream>
#include<stdio.h>
#include<queue>
#include<string.h>
using namespace std;
const int maxInt=500;
int N,A,B;
int a[205];
int graph[205][205];
int ss[205];
bool visit[205];
void BFS()
{
queue<int> qu;
memset(visit,false,sizeof(visit));
qu.push(A);
visit[A]=true;
ss[A]=0;
bool flag=false;
while(!qu.empty())
{
int u=qu.front();
if(u==B)
{
printf("%d\n",ss[B]);
flag=true;
break;
}
qu.pop();
for(int i=1;i<=N;i++)
{
if(graph[u][i]!=maxInt&&!visit[i])
{
qu.push(i);
visit[i]=true;
ss[i]=ss[u]+1;
}
}
}
if(!flag)
printf("-1\n");
}
int main()
{
//freopen("D://ACMInput/input.txt","r",stdin);
while(scanf("%d",&N))
{
if(N==0)
break;
scanf("%d%d",&A,&B);
for(int i=1;i<=N;i++)
{
for(int j=1;j<=N;j++)
graph[i][j]=i==j ? 0 : maxInt;
}
for(int i=1;i<=N;i++)
{
scanf("%d",&a[i]);
if(i+a[i]<=N)
graph[i][a[i]+i]=1;
if(i-a[i]>=1)
graph[i][i-a[i]]=1;
}
BFS();
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: