您的位置:首页 > 编程语言 > Go语言

UVa 10879 - Code Refactoring

2012-09-01 20:25 169 查看
Problem B
Code Refactoring
Time Limit: 2 seconds

"Harry, my dream is a code waiting to be

broken. Break the code, solve the crime."
Agent Cooper

Several algorithms in modern cryptography are based on the fact that factoring large numbers is difficult. Alicia and Bobby know this, so they have decided to design their own encryption scheme  based on factoring. Their algorithm depends
on a secret code, K, that Alicia sends to Bobby before sending him an encrypted  message. After listening carefully to Alicia's description, Yvette says,  "But if I can intercept
K and factor it into two positive  integers, A and
B, I would  break your encryption scheme!  And the K values you use are at most 10,000,000. Hey, this is  so easy; I can even factor it twice, into two different pairs of  integers!"
Input

The first line of input gives the number of cases, N (at most 25000).
N test cases follow. Each one contains the code, K, on a line by itself.
Output

For each test case, output one line containing  "Case #x:
K
= A * B = C *
D
",  where A, B, C and
D are different positive integers larger than 1. A solution will always exist.
Sample InputSample Output
3
120
210
10000000

Case #1: 120 = 12 * 10 = 6 * 20
Case #2: 210 = 7 * 30 = 70 * 3
Case #3: 10000000 = 10 * 1000000 = 100 * 100000

Problemsetter: Igor Naverniouk

对于这道题目其实非常简单,但是看样例输入和样例输出 却很容易让人糊涂,其实只要是找出a*b=k的即可,这题的结果并不唯一。

#include <stdio.h>
#include <string.h>
#include <math.h>
int main()
{
int i,j,n,m,s,t,t1;
scanf("%d",&t);
t1=1;
while(t--)
{
scanf("%d",&n);
i=2;
j=0;
while(1)
{
if(n%i==0)
{
if(j==0)
{
printf("Case #%d: %d = %d * %d",t1,n,i,n/i);
j=1;
}else
{
printf(" = %d * %d\n",i,n/i);
break;
}
}
i++;
}
t1+=1;
}
return 0;
}


 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息