您的位置:首页 > 编程语言 > Go语言

POJ 2007 Scrambled Polygon(计算几何---凸包)

2012-05-07 11:19 411 查看
Scrambled Polygon

Time Limit: 1000MS

Memory Limit: 30000K

Total Submissions: 4906

Accepted: 2327

Description

A closed polygon is a figure bounded by a finite number of line segments. The intersections of the bounding line segments are called the vertices of the polygon. When one starts at any vertex of a closed polygon and traverses each bounding line segment exactly once, one comes back to the starting vertex.

A closed polygon is called convex if the line segment joining any two points of
the polygon lies in the polygon. Figure 1 shows a closed polygon which is
convex and one which is not convex. (Informally, a closed polygon is convex if
its border doesn't have any "dents".)



The subject of this problem is a closed convex polygon in the coordinate plane, one of whose vertices is the origin (x = 0, y = 0). Figure 2 shows an example. Such a polygon will have two properties significant for this problem.

The first property is that the vertices of the polygon will be confined to
three or fewer of the four quadrants of the coordinate plane. In the example
shown in Figure 2, none of the vertices are in the second quadrant (where x
< 0, y > 0).

To describe the second property, suppose you "take a trip" around the
polygon: start at (0, 0), visit all other vertices exactly once, and arrive at
(0, 0). As you visit each vertex (other than (0, 0)), draw the diagonal that
connects the current vertex with (0, 0), and calculate the slope of this
diagonal. Then, within each quadrant, the slopes of these diagonals will form a
decreasing or increasing sequence of numbers, i.e., they will be sorted. Figure
3 illustrates this point.





Input

The input lists the vertices of a closed convex polygon in the
plane. The number of lines in the input will be at least three but no more than
50. Each line contains the x and y coordinates of one vertex. Each x and y
coordinate is an integer in the range -999..999. The vertex on the first line
of the input file will be the origin, i.e., x = 0 and y = 0. Otherwise, the
vertices may be in a scrambled order. Except for the origin, no vertex will be
on the x-axis or the y-axis. No three vertices are colinear.

Output

The output lists the vertices of the given polygon, one vertex per
line. Each vertex from the input appears exactly once in the output. The origin
(0,0) is the vertex on the first line of the output. The order of vertices in
the output will determine a trip taken along the polygon's border, in the
counterclockwise direction. The output format for each vertex is (x,y) as shown
below.

Sample Input

0 0

70 -50

60 30

-30 -50

80 20

50 -60

90 -20

-30 -40

-10 -60

90 10

Sample Output

(0,0)

(-30,-40)

(-30,-50)

(-10,-60)

(50,-60)

(70,-50)

(90,-20)

(90,10)

(80,20)

(60,30)

Source

Rocky Mountain 2004

解题报告:这道题就是求形成凸包的点,输出的时候以(0, 0)开始,按逆时针的方向输出(其实用Graham()算法选取点就是按照逆时针选取的)!

代码如下:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <algorithm>
using namespace std;
const int MAX = 55;
int n, top = 1;
int convex[MAX];//记录形成凸包的点的次序按逆时针
struct Point//存储点的坐标
{
double x;
double y;
}p[MAX];
int cmp(Point a, Point b)//先按y从小到大排序,若y相等,再按x从小到大排序
{
if (a.y == b.y) return a.x < b.x;
return a.y < b.y;
}
double Multi(Point p1, Point p2, Point p3)//利用叉乘判断点的位置
{
return (p1.x - p3.x) * (p2.y - p3.y) - (p1.y - p3.y) * (p2.x - p3.x);
}
void Graham()//选取点形成凸包(不包含边上的点)选取的点数是最小的,按逆时针选择的
{
int i, count;
top = 1;
sort(p, p + n, cmp);
for (i = 0; i < 3; ++i)
{
convex[i] = i;
}
for (i = 2; i < n; ++i)
{
if (top && Multi(p[i], p[convex[top]], p[convex[top - 1]]) >= 0)
{
top --;
}
convex[++ top] = i;
}
count = top;
convex[++ top] = n - 2;
for (i = n - 3; i >= 0; --i)
{
if (top != count && Multi(p[i], p[convex[top]], p[convex[top - 1]]) >= 0)
{
top --;
}
convex[++ top] = i;
}
}
int main()
{
int i, flag;
n = 0;
while (scanf("%lf%lf", &p
.x, &p
.y) != EOF)
{
n ++;
}
Graham();
for (i = 0; i < top; ++i)//先找到坐标为(0,0)的点在构成凸包时的位置
{
if (p[convex[i]].x == 0 && p[convex[i]].y == 0)
{
flag = i;
break;
}
}
for (i = flag; i < top + flag; ++i)//输出结果
{
printf("(%.0lf,%.0lf)\n", p[convex[i % top]].x, p[convex[i % top]].y);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: